domingo, 23 de noviembre de 2014

Formato De Los Mensajes de Correo Electrónico

Un mensaje de correo electrónico está dividido en tres partes;  encabezado, cuerpo de mensaje y datos adjuntos.

Encabezado

El encabezado del mensaje normalmente no está a la vista de quien lo recibe más sin embargo la mayoría de todos los programas de correo electrónico permite examinarlo.

Las líneas más importantes del encabezado son:
   
    o From:        Es la dirección del remitente. Solo puede haber una línea de este tipo en el
                         encabezado.
                   
    o To:           El o los destinatarios de este mensaje. Esta línea puede especificar más de
                       una dirección de destino.
                               
    o Cc:           Copia a destinatarios. Esta equivale a la copia en papel carbón en el caso   
                       del correo normal. Se manda a los destinatarios indicados una copia  
                       (meramente informativa) de la carta.          

    o Bcc:          Esta seria una copia oculta. Se mandara una copia a la dirección aquí
                        indicada sin que los otros destinatarios tengan conocimiento de ello.  
                   
    o Subject:    Tema del mensaje. El texto es libre, pero es conveniente elegir uno que 
                        sea breve y que describa el contenido del mensaje.
                 
    o Date:         Indica la fecha y hora en que el mensaje fue enviado.    
                   
  o Message-Id:   Es un identificador de cada mensaje, este es unico y lo inserta el 
                            ordenador que lo envia.
     
  o Received:    Es la información que se utiliza para comprobar los problemas que hayan     
                         aparecido en el reparto de un mensaje. Se muestran las direcciones de las
                         maquinas, junto con la fecha y hora en que el mensaje paso por ellas en   
                         dirección a su destino. 
         
o Resent-From:  Dirección de la persona o programa desde el cual llega el mensaje. El
                           hecho de decir reenviado te notifica que el mensaje le ha llegado a la
                           persona que se indica en este campo y ella a su vez te manda una copia.
           
                   
o Reply-To:     Obviamente, la direccion a la que debes contestar. No tiene que ser la
                       misma desde donde se ha enviado la carta.    
                   




Cuerpo de mensaje

Es el mensaje en si, tal como lo ve en la pantalla. Puede estar redactado en formato de texto plano y/o HTML, es decir como una página web lo que permite darle formato al texto utilizar un gráfico de fondo, etc.

Datos adjuntos o Attachments

La gran mayoría los programas de correo electrónico actuales tiene la posibilidad de adjuntar al texto del mensaje, un archivo, usualmente residente en el disco de su computadora. Este archivo puede ser de cualquier tipo programa ejecutable (.exe ) archivo comprimido (.zip) imagen gráfica (GIF o JPG ) etcétera.




Protocolo de Correo Electrónico

Hoy día, el correo electrónico es entregado usando una arquitectura cliente/servidor. Un mensaje de correo electrónico es creado usando un programa de correo cliente. Este programa luego envía el mensaje a un servidor. El servidor luego lo redirige al servidor de correo del recipiente y allí se le suministra al cliente de correo del recipiente.

Para permitir todo este proceso, existe una variedad de protocolos de red estándar que permiten que diferentes máquinas, a menudo ejecutando sistemas operativos diferentes y usando diferentes programas de correo, envíen y reciban correo electrónico o email.

Hay dos protocolos principales usados por las aplicaciones de correo cliente para recuperar correo desde los servidores de correo: el Post Office Protocolo (POP) y el Internet Message Access Protocol (IMAP).

POP
El servidor por defecto POP bajo Red Hat Enterprise Linux es /usr/sbin/ipop3d y es proporcionado por el paquete imap. Cuando se utiliza POP, los mensajes de correo son descargados a través de las aplicaciones de correo cliente. Por defecto, la mayoría de los clientes de correo POP son configurados para borrar automáticamente el mensaje en el servidor de correo después que éste ha sido transferido exitosamente, sin embargo esta configuración se puede cambiar.
POP es completamente compatible con estándares importantes de mensajería de Internet, tales como Multipurpose Internet Mail Extensions (MIME), el cual permite los anexos de correo.Funciona mejor para usuarios que tienen un sistema en el cual leer correo. También funciona bien para usuarios que no tienen una conexión permanente a la Internet o a la red que contiene el servidor de correo. La versión más reciente del protocolo estándar POP es POP3.

IMAP
El servidor por defecto IMAP bajo Red Hat Enterprise Linux es /usr/sbin/imapd y es proporcionado por el paquete imap. Cuando utilice un servidor de correo IMAP, los mensajes de correo se mantienen en el servidor donde los usuarios pueden leerlos o borrarlos. IMAP también permite a las aplicaciones cliente crear, renombrar o borrar directorios en el servidor para organizar y almacenar correo. Lo utilizan principalmente los usuarios que acceden a su correo desde varias máquinas. El protocolo es conveniente también para usuarios que se estén conectando al servidor de correo a través de una conexión lenta, porque sólo la información de la cabecera del correo es descargada para los mensajes, hasta que son abiertos, ahorrando de esta forma ancho de banda. El usuario también tiene la habilidad de eliminar mensajes sin verlos o descargarlos.
IMAP, como POP, es completamente compatible con estándares de mensajería de Internet, tales como MIME, que permite los anexos de correo.

PROTOCOLO SMTP:
Protocolo simple de transferencia de correo (SMTP) está diseñado para transferir correo confiable y eficiente. Se utiliza ampliamente en instalaciones gubernamentales y de educación y también es el estándar utilizado en Internet para transferir correo. 

El protocolo Simple de transferencia de correo sería un protocolo "capa de aplicación" cuando en el modelo OSI. Es un protocolo abierto porque la única suposición que hace del mecanismo de transporte debajo de él es que proporcionará un servicio confiable. 

En la mayoría de los casos, SMTP se utiliza junto con el servicio de protocolo de Control de transmisión (TCP), que proporciona la capa de transporte confiable (servicio). Otros mecanismos de transporte que se mencionan como compatible con la especificación son el servicio de programa de Control de red (NCP), el servicio de transporte independiente (NITS) de red y el servicio X.25. 

Solicitudes de comentarios (RFC) proporcionan especificaciones para el protocolo: 


RFC-821 especifica el protocolo de intercambio y es la base para SMTP.

RFC-822 especifica el formato del mensaje.


EXTENSIONES MIME:

MIME (Extensiones Multipropósito de Correo Internet) es un estándar propuesto en 1991 por Bell Communications para expandir las capacidades limitadas del correo electrónico y en particular para permitir la inserción de documentos (como imágenes, sonido y texto) en un mensaje. Fue definido originalmente en junio de 1992 por las RFC 1341 y 1342.
MIME describe el tipo de contenido del mensaje y el tipo de código usado con encabezados.
MIME incorpora las siguientes características al servicio de correo electrónico:
Capacidad de enviar múltiples adjuntos en un solo mensaje
Longitud ilimitada del mensaje
Uso de conjuntos de caracteres no pertenecientes al código ASCII
Uso de texto enriquecido (diseños, fuentes, colores, etc.)
Adjuntos binarios (ejecutables, imágenes, archivos de audio o video, etc.), que se pueden dividir de ser necesario
MIME usa directivas especiales en los encabezados para describir el formato utilizado en el cuerpo de un mensaje, de modo que el cliente de correo electrónico pueda interpretarlo correctamente:
Versión de MIME: esta es la versión de MIME estándar usada en el mensaje. Actualmente sólo existe la versión 1.0.
Tipo de contenido: describe el tipo y el subtipo de datos. Puede incluir un parámetro de "juego de caracteres", separado por un punto y coma, que define qué juego de caracteres utilizar.
Codificación de transferencia de contenido: define la codificación usada en el cuerpo del mensaje.
Identificación de contenido: representa una identificación única para cada segmento del mensaje.
Descripción de contenido: proporciona información adicional sobre el contenido del mensaje.
Disposición de contenido: define la configuración de los adjuntos, particularmente el nombre vinculado al archivo, usando el atributo nombre del archivo.Los tipos de MIME, usados en el encabezado Tipo de contenido, se usan para clasificar los documentos adjuntos de un correo electrónico


No hay comentarios:

Publicar un comentario